Конференция "Сети" » Старый Indy и httpS [D7]
 
  • Лакримакристи (27.03.14 13:07) [0]
    Есть ли способ заставить Indy, идущий в комплектации Delphi7SP2, работать с "https://"?
    Все советы что напоисковиковикачил либо отказаться от Indy, либо обновить Indy до новой версии.
    А нужно именно на Indy, и именно на той что базовая в Delphi7.
  • DQ (28.03.14 23:45) [1]
    Это пробовали?: http://devdelphi.ru/?p=1192
    Там правда кажется про более новый Indy.
  • Дмитрий Белькевич (30.03.14 12:30) [2]
    Насколько я помню - в разных OpenSSL либах немного разное апи, возможно имеет смысл попробовать более старые либы. Или всё таки пробовать переползти на новые инди.
  • vegarulez (12.11.14 01:36) [3]
    Я решил проблему поставив новые инди indy indy10.1.5_d7.exe + обновил 2 всем известные бибилиотечки для работы с SSL (ssleay32.dll, libeay32.dll)

    Советы по отказу правильные - инди уже давно не поддерживается и не обновляется.
  • Дмитрий Белькевич © (20.11.14 09:49) [4]
    >инди уже давно не поддерживается и не обновляется.

    инди довольно активно правится и постоянно обновляется (вижу по тысячам исправлений исходников). обновлять нужно, будет работать.
 
Конференция "Сети" » Старый Indy и httpS [D7]
Есть новые Нет новых   [120572   +211][b:0][p:0]